1. Este sitio usa cookies. Para continuar usando este sitio, se debe aceptar nuestro uso de cookies. Más información.
  2. Invitado, ¿no puedes iniciar conversaciones privadas? ¿Tu buzón está lleno? Prueba a "abandonar charlas" para liberar espacio de tu buzón .
    Descartar aviso

[QLandkarteGT] Hilo para centralizar dudas, experiencias y comentarios

Tema en 'GPS' iniciado por dardhal, 2 Jun 2011.

  1. dardhal

    dardhal Miembro Reconocido

    Registrado:
    26 Sep 2005
    Mensajes:
    2.382
    Me Gusta recibidos:
    35
    Ubicación:
    Madrid
    Hola juancar_lo, los mapas en línea a los que QLGT da acceso mediante el menú Archivo -> Cargar Mapa Online son aquellos que públicamente accesibles mediante protocolo WMS, alguien ha creado una definición XML para los mismos (tal cual se ha comentado en este mismo hilo), y el autor del mapa lo ha puesto a disposición de todos los usuarios.

    Si dispones de la URL de una página web que sirva mapas según estándar WMS, bien porque la extraigas de otro programa, bien porque la obtengas desde la web de quien proporciona el mapa, se puede crear la definición XML e incorporar el mapa a QLGT.

    Por supuesto, también puedes visualizar mapas vectoriales Garmin en QLGT, tanto si los tienes disponibles como un conjunto de IMG más un TDB, como si sólo tienes el gmapsupp.img correspondiente (en este caso, tras convertir el gmapsupp.img en sus correspondientes IMG más TDB mediante algo como GMapTool).
     
  2. kerkus2

    kerkus2 Novato

    Registrado:
    5 Ene 2014
    Mensajes:
    2
    Me Gusta recibidos:
    0
     
  3. kerkus2

    kerkus2 Novato

    Registrado:
    5 Ene 2014
    Mensajes:
    2
    Me Gusta recibidos:
    0
    Después de seguir todo el proceso sin error, la aplicación se abre pero NO cambia a español.
    Utilizo Ubuntu, versión: 1204 LTS, y Qlandkartegt, versión 1.2.3.
    Agradecería alguna sugerencia para resolver el problema.
     
  4. dardhal

    dardhal Miembro Reconocido

    Registrado:
    26 Sep 2005
    Mensajes:
    2.382
    Me Gusta recibidos:
    35
    Ubicación:
    Madrid
    Aunque ha pasado una vida desde que hiciste la pregunta , a veces hacer las cosas por la interfaz gráfica es más complicado que yéndose a la línea de comandos.

    En este caso, si ya tienes lanzado una línea de comandos (busca "xterm" en el lanzador de aplicaciones), ejecutar lo siguiente debería bastar para mostrat QLandkarteGT, o cualquier otro software, en castellano:
    CODE, HTML o PHP Insertado:
    LANG=es qlandkartegt
    Por lo demás, QLGT 1.2.3 es una versión antiquísima, no es que haya habido grandes novedades últimamente (de ahí que no haya actualizado el hilo en mucho tiempo), pero vamos por la 1.7.6, y con la 1.2.3 habrá muchas de las cosas que se comentan en este hilo que no existan en tu versión.

    En la más reciente versión de Ubuntu 14.04 LTS, ya viene la 1.7.5, y por lo tanto, dependiendo de porqué sigas con la Ubuntu 12.04 LTS, quizás sea un buen momento para actualizar.
     
  5. dardhal

    dardhal Miembro Reconocido

    Registrado:
    26 Sep 2005
    Mensajes:
    2.382
    Me Gusta recibidos:
    35
    Ubicación:
    Madrid
    Unos breves apuntes en relación al programa que da nombre al hilo:
    - En Ubuntu 14.10 (la más reciente versión de Ubuntu de la más popular versión de Linux) viene de serie QLGT 1.7.7-2, en el repositorio "universe"
    - El autor de QLGT ya no ve características notables a faltar en el software, y sí limitaciones de arquitectura (diseño) para meter cosas que le gustaría. Por ello, desde el verano ha estado impulsando su nueva criatura, QMapShack, que pretende empezar desde cero un software de propósito similar a QLGT, pero mejor pensado, y adaptado a las necesidades actuales. Los destalles del nuevo software están en https://bitbucket.org/maproom/qmapshack/wiki/Home

    Así que el presente hilo , vinculado a QLGT, posiblemente no vea muchas actualizaciones en el futuro, pues el software no incluirá mucho más de lo que ya tiene, que no es poco, pero aún podemos usarlo para ayudarnos mutuamente o comentar cómo hacer cosas que puedan resultar interesantes.

    En cualquier caso, para aquellos que se manejen con el idioma inglés, preferiblemente que sean conscientes de lo complejo que es implementar hasta la más mínima nueva característica, y sobre todo, para aquellos con la mano izquierda necesaria para tratar con desarrolladores (y la templanza necesaria para aceptar sus determinaciones), puede ser un buen momento para involucrarse en un proyecto vivo, y promover/ayudar con aquellas características que siempre quisiste tener en un software como este, pero nunca nadie se dignó a añadir.
     
    • Me Gusta Me Gusta x 2
  6. sxpacoxs

    sxpacoxs Miembro activo

    Registrado:
    21 Ago 2012
    Mensajes:
    521
    Me Gusta recibidos:
    44
    Gracias Dardhal, aunque no soy capaz de sacar todas las posibilidades que ya tiene QLandkarte, seguiremos atentamente la evolución del nuevo proyecto.
     
  7. Trisk3l

    Trisk3l Outra vaca no millo

    Registrado:
    6 Ago 2008
    Mensajes:
    2.829
    Me Gusta recibidos:
    1.807
    Ubicación:
    Donde la lluvia es arte
    La verdad es que con QLandkarte estoy más que satisfecho pero bienvenido sea el nuevo proyecto. Sin duda lo seguiré.
     
  8. pepitopatan

    pepitopatan Novato

    Registrado:
    11 Dic 2011
    Mensajes:
    6
    Me Gusta recibidos:
    0
    Hola, yo estoy empezando con Qlandkarte. Antes tenía un PC y me permití hacer algunos mapas (ortofotos) en el proyecto para completar todas las cuadrículas de España. Era entretenido y aprendí mucho (creía). Ahora he heredado de un amigo un Mac OS con pantalla grande y estoy encantado pero... como sospecháis mi problema es que no abre el formato ECW, que se impone en todos los servidores gratuitos de cartografía y de ortofotos.
    He leído casi todo lo que hay por los foros escrito (en serio) , pero no hay manera.
    Mi Mac carga el Mac Os 10.6.8.
    Instalo, por este orden,
    la librería GDAL Complete 1.10
    GDAL -ECW Plugin 1.10.1
    QLandkarte 1.7.7


    Y nada. No hay manera.
    He leído la propuesta de modificar un archivo (localiza el fichero ecw_cs.wkt ) para que el programa lea ECW xon datum ETRS89 que aportó Michelín, pero claro, yo tampoco encuentro ese archivo que es exclusivo de Linux, parece.
    En fin, si alguien quiere orientarme un poco lo agradeceré.
     
  9. dardhal

    dardhal Miembro Reconocido

    Registrado:
    26 Sep 2005
    Mensajes:
    2.382
    Me Gusta recibidos:
    35
    Ubicación:
    Madrid
    En Linux, nos tocó compilar las librerías de GDAL contra el antiguo SDK de ECW para tener soporte. En MacOS parece que alguien hubiera compilado un paquete con dicho soporte, así que eso te lo ahorras. Si GDAL ya tiene soporte, con "gdalinfo --formats" debería salir el formato entre los soportados. Y de ser así QLGT debería cargar el mapa como debería con cualquier otro mapa georreferenciado cuyo formato soporte GDAL.

    De quejarse QLGT de la proyección, con las herramientas de GDAL podrías reproyectar el mapa en caso necesario, pero lo primero es ver que "gdalinfo --formats" lista ECW entre los formatos, en caso contrario QLGT no podrá hacer nada al respecto.
     
  10. pepitopatan

    pepitopatan Novato

    Registrado:
    11 Dic 2011
    Mensajes:
    6
    Me Gusta recibidos:
    0
    Gracias por tu rápida respuesta pero hay cosas que no entiendo. Cuando me dices que haga una comprobación en "gdalinfo --formats" entiendo que es un archivo que puedo abrir? Cómo lo busco? A través del Spotlight o con algún comando en terminal? Perdona pero no sé como hacerlo. Luego dices que "con las herramientas de GDAL podrías reproyectar el mapa en caso necesario". Con qué herramientas? Dónde se activan?
    Por otra parte, si he instalado el plugin esepecífico para ECW por qué no abre? Puede ser que no se instale en el sitio adecuado?. Perdonar tantas dudas...
     
  11. dardhal

    dardhal Miembro Reconocido

    Registrado:
    26 Sep 2005
    Mensajes:
    2.382
    Me Gusta recibidos:
    35
    Ubicación:
    Madrid
    Yo hablo de lo que conozco, que es Linux, y lo que decía de ejecutar "gdalinfo --formats" es desde la línea de comandos. Pero otra opción es arrancar el QLGT e irse al menú Ayuda -> Acerca de QLandkarteGT -> Formatos, y lo que sale ahí es básicamente lo mismo que ejecutar "gdalinfo --formats", y si ahí no sale ECW, entonces QLGT no puede hacer nada al respecto, pues usa GDAL para el soporte de formatos.

    Lo otro que decía, reproyectar, es por lo que preguntabas inicialmente de que "para que el programa lea ECW con datum ETRS89". Eso se puede hacer con gdal/ogr, utilidades de línea de comandos, en el caso de que tus ECW estuvieran proyectad
    os en un datum que la aplicación no entendiera. Pero antes de llegar a eso tienes que conseguir que tu GDAL entienda ECW, para lo cual más allá de lo que te he comentado, yo no puedo ayudarte (no tengo Mac OS en ninguna de sus presentaciones).

    Un saludo.
     
  12. pepitopatan

    pepitopatan Novato

    Registrado:
    11 Dic 2011
    Mensajes:
    6
    Me Gusta recibidos:
    0
    Gracias de nuevo.
    Efectivamente no aparece ECW como formato soportado. Tras un largo listado de formatos aparece esto:

    Entorno GDAL

    PATH = /usr/bin:/bin:/usr/sbin:/sbin

    GDAL_DATA =

    GDAL_DRIVER_PATH =

    PROJ_LIB =
    Quiero entender que no encuentra la ruta de GDAL. Alguien sabría como y donde corregirlo.
     
  13. dardhal

    dardhal Miembro Reconocido

    Registrado:
    26 Sep 2005
    Mensajes:
    2.382
    Me Gusta recibidos:
    35
    Ubicación:
    Madrid
    Si el GDAL no estuviera bien instalado o integrado con QLGT, éste simplemente no funcionaría con ningún mapa (de hecho, no funcionaría en absoluto).

    El problema, parece ser, que la instalación de GDAL-ECW Plugin 1.10.1 _parece_ no ser suficiente para que el GDAL reconozca este formato. Muchas veces el software no completamente libre , tal como las librerías de soporte para ECW, tienen
    la necesidad de configuración adicional por parte del usuario para funcionar.

    Olvídate de QLGT, pues es un simple usuario de las librerías. Céntrate en conseguir soporte funcional de ECW para GDAL en MacOS X. Como hay muchos programas que usan GDAL, y ECW es un formato muy común, busca referencias omitiendo el QLGT,
    te saldrán muchos enlaces, y finalmente, cuando el GDAL entienda ECW, también lo hará por extensión QLGT.

    Lamento no ser más específico, pero no tengo ningún MacOS X, soy un pobre usuario de Linux.
     
  14. pepitopatan

    pepitopatan Novato

    Registrado:
    11 Dic 2011
    Mensajes:
    6
    Me Gusta recibidos:
    0
    Gracias. Lo intento.
     
  15. davidirigaray

    davidirigaray Miembro activo

    Registrado:
    4 Oct 2009
    Mensajes:
    577
    Me Gusta recibidos:
    60
    Ubicación:
    Castellon de la plana
    Queria una guia para comenzar a ver si podriais ayudarme, gracias
     
  16. Decartón

    Decartón Miembro

    Registrado:
    23 Jun 2005
    Mensajes:
    123
    Me Gusta recibidos:
    1
  17. mitxelin

    mitxelin Novato

    Registrado:
    14 Jul 2011
    Mensajes:
    29
    Me Gusta recibidos:
    0
    Hola pepitopatan

    Yo tampoco uso Mac, pero buscando informacion para un colega que esta en el mismo trance que tu encontre esto:

    https://www.mapbox.com/tilemill/docs/guides/gdal/

    Mac OS X

    On Mac OS X you can install the “GDAL Complete” Framework from kyngchaos.com.

    GDAL applications are run through the Mac OS X Terminal. The first time you install the GDAL package there is one additional step to make sure you can access these programs. Open the Terminal application and run the following commands:

    echo 'export PATH=/Library/Frameworks/GDAL.framework/Programs:$PATH' >> ~/.bash_profile
    source ~/.bash_profile

    You should now be ready to go. To test your installation, run the Terminal command gdalinfo --version. A correct installation will output something like GDAL 1.9.0, released 2011/12/29.

    Imagino que con esos pasos le dices a tu MAC OS X donde encontrar GDAL.

    Sobre el datum ETRS89 con ECW: como ya has instalado GDAL 1:10 no deberias tener problemas por que en esa version ya esta en la lista de datums disponibles para ecw.

    Cuentanos como te ha ido y si lo has solucionado que seguro ayuda mas de uno. ( A ver si mi colega tambien lo consigue, aun no se.)

    Saludos

     
  18. periku39

    periku39 Novato

    Registrado:
    11 Mar 2011
    Mensajes:
    16
    Me Gusta recibidos:
    2
    Problemas con qlandkartegt 1.8.1 .

    Hola a todos , he instalado en xubuntu 15.10 qlandkarte 1.8.1 ,el caso es que cuando cargo los mapa desde la opcion cargar mapas los instalo con normalidad y sin embargo cuando cierro el programa al volver arrancarlo no se quedan guardados ,con la version anterior no me pasaba.Otra cosa que me pasa es que es que cofiguro el gps ,un etrex legend hcx ,y no consigo que me carge un track en el gps , es mas, se apaga el programa y cuando lo vuelvo a arrancar tampoco me ha guardado la configuracion .

    A ver si alguien arroja luz sobre el tema.

    Un saludo.
     
  19. toliao

    toliao Novato

    Registrado:
    22 Ago 2015
    Mensajes:
    13
    Me Gusta recibidos:
    1
    has conseguido un paquete .deb de la version 1.8.1 o lo has compilado tu? El unico paquete compilado que yo he encontrado de esa version es para opensuse y no me funciono, ni siquiera se iniciaba.
    No se darte respuesta a tus problemas solo que yo tampoco tengo ninguno con la 1.7.5 y con la 1.8.1 que probe ya te he dicho antes
     
  20. Trisk3l

    Trisk3l Outra vaca no millo

    Registrado:
    6 Ago 2008
    Mensajes:
    2.829
    Me Gusta recibidos:
    1.807
    Ubicación:
    Donde la lluvia es arte
    En Ubuntu 15.10 la 1.8.1 es la versión que está en los repositorios.
     

Compartir esta página